T-Shirt Forums banner
1 - 4 of 4 Posts

· Registered
Joined
·
37 Posts
Discussion Starter · #1 · (Edited)
Good morning,

For those who are looking to convert their Melco EMT & EMC (single or 4 heads) machines to usb, here is how I have done it for less than 50$.


(my machine with the usb floppy drive installed)

First:
- The "emulator" needs to be the SFRM72-FU. SFR1M44-XX will not work. Melco uses 720k. I bought this one for 49$ shipping included.
- Works without any problem on my machine (Melco EMT 10/4T from Dec 1998)
- The usb memory sticks needs to be in FAT or FAT32 format (default). I'm using a common 4GB TDK stick:


Preparing the boot disks

1) Download the file corresponding your machine type:
- Single head: Download
- 4 Head: Download

2) Plug your usb memory to your computer.
3) Execute the downloaded file and uncompress the content to the USB.
4) Your USB memory is now a "booting disk".

Installation:

1)



2)
Remove the floppy unit from the case. Unplug the 34 pin cable and the power cord.

3)



4) Plug the cables in the new unit. Once replaced, proceed to reassemble again the machine.

5) Your machine is ready to read from usb.

Have a nice day and sorry about my english mistakes.

Bernina.
 

· Registered
Joined
·
37 Posts
Discussion Starter · #5 ·
Thank you all.

I am curious as to how you set up the usb for booting of the machine. I have a EMC-10T & tried to convert to a floppy emulator several months ago. I copied the files from the boot disk to the usb but the machine would not boot up. Could you explain how yours works? Thank you.
Hi lstark, I have updated the first post with the files needed to create the "usb boot disk". Just copy and paste the files to your usb memory, plug it to your machine and it will boot up if everythink is ok.

Thank you for this, I have tried two other drives both were 1.44 compatible and did not work, I now know what to try next.

Tommy
Hi Tommi. 1.44 drives don't work with this machines, only 720k drives. I have installed the unit with the reference "SFRM72-FU". The floppy drive with the reference "SFR1M44-XX" will not work.
 

· Registered
Joined
·
37 Posts
Discussion Starter · #9 ·
Help please, I ordered the usb drive by following your link for the one that you purchased and it came today. I downloaded and installed the singlehead file onto a 2G usb drive but the machine still won't see it. I changed the jumper as you showed in your directions. I assume that I am doing something wrong but I don't know what it is. :confused:

My machine is an EMC10-T single head from around 1995. I would appreciate any suggestions that you can make. TIA!!
Hi lstark!

Does your machine boots up? Does your display shows any message?

Format your usb drive to FAT32, extract the files. Switch on your machine, when the display shows something like "INSERT BOOT DISK", insert your disk and press ENTER.

Nice to help you.
 

· Registered
Joined
·
37 Posts
Discussion Starter · #11 ·
My USB drive was formatted as FAT(default) so I reformatted it to FAT32. I extracted the single head boot file on the USB drive. Turned on the machine, it shows "checking RAM" then "DiskBios 1.7 992k", then "insert boot disk". I put the usb drive in and press enter, it shows "trying network", then flashes back & forth between "DiskBios 1.7 992 K & unit 01" then finally says "insert book disk".
I have power to the drive unit (green light & red 000). I have tried selecting 000, 001, 010, all with no effect.

I have also tried copying the boot files from the floppy disk (they have different names "edsapp9a.rsa, edsapp9b.rsa, edsapp9c.rsa, edsapp99.rsa" then what is in the one I downloaded from here), with the same results.

I don't know what else to try.:eek: Thank you for any suggestions.
Good morning Lori,

Check if the 34 pin cable is connected upside down; I had the same problem when tried for the first time. Plug the cables and try it before reassemble the machine.

Format the usb to fat32 and extract the files. You don't have to press any button of the floppy "emulator".

Keep in touch,

Have a nice day.
 
1 - 4 of 4 Posts
Top