T-Shirt Forums banner

1 - 6 of 6 Posts

·
Registered
Joined
·
111 Posts
Discussion Starter #1
Read a couple of old threads but still cant get my answer. I have a kiosk II with the wims system. Just installed a new printhead, 4 new CMYK dampers, new cap assembly and 3 new White ink dampers(for the 1st time). On my invoice the white dampers say they are for HM1/Viper/HMXpr/Bul.(its 10.45 pm in Australia now and will ring suppliers in morning but thought might get an answer here) Are they suitable for my kiosk. Looking at them they seem similar except the new ones have a thread on the inlet end and they dont seem to be as snug a fit on the printhead. did nozzle checks and colours are great,but no white. Syringed the white dampers and seemed to fill up ok in the 1st section but not the next.But noticed that on the old ones the ink only filled the oval section (where the filter inside is) but on the new seemed to that area and above(this happened on all 3), came along into the round section but could not completely fill it. Tried nozz checks again still no white.
Have they sent the right ones as all 3 couldnt be faulty?
hope someone can help
cheers
olly
 

·
Registered
Joined
·
76 Posts
We have a WIMS system as well, and I actually had to take a mat knife and cut the extra bit off the damper (the part that connects to the white ink line). I called our service people first, and that is what they told me to do - it's what they do.

I don't know if this is the case for your machine, but hoping it helps.
 

·
Registered
Joined
·
111 Posts
Discussion Starter #4
Do you have a picture of what they look like??
New one on the right
Notice how the ink filled up the whole section where as the old one it only filled the oval where the filter is. After a closer look the top has been cut off. hope this is the problem
 

Attachments

·
Registered
Joined
·
12 Posts
Hey...olly
Did you solve your problem with dampers?
I have same machine and...just about to change dampers first time...since I bought machine.
Can you show me your settings?
 

·
Registered
Joined
·
111 Posts
Discussion Starter #6
Hey...olly
Did you solve your problem with dampers?
I have same machine and...just about to change dampers first time...since I bought machine.
Can you show me your settings?
Austin,
it ended up being a faulty head which i replaced. Still don't think the dampers are snug enough on the head but they are working fine now. As said above you have to cut the top off if you,ve got the thread on it
cheers
Olly
 
1 - 6 of 6 Posts
Top