T-Shirt Forums banner
1 - 13 of 13 Posts

· Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
Hi there,

I am new to this forum, and hope some of you can help me on this... Last Friday I was working on a project, my Expert 24 was cutting just right, but something happened and now it simply does not work.

I tried every suggestion I found, as the checklist below:

Turn on / off
Hit data clear
Cut test
Confirm Expert 24 firmware set to 64 bits
Confirm if PC recognizes device when turned on
VLCD3 recognizes plotter port and plotter performs VLCD3 scaling test
Remove / reinstall drivers x64
Disconnect / connect USB cable
change USB port
change USB cable
Format PC
Reinstall OS / Programs
Disable antivirus
Cleanup obsolete registry keys

I use Windows 7 x 64 Ultimate + CorelDRAW X6

I also had support from local dealer, who gave up after more than an hour trying to remotely set up my PC and doing lots of testings with no results. He said he never saw this kind of problem before and went out to find out additional support.
:(
I also requested tech support at GCC Laser Cutters, Laser Engravers, Vinyl Cutter, Printer/Cutters but had no reply yet.

Does anybody have an insight on anything I forgot? Please help.

Thank you very much!
 

· Registered
Joined
·
3,098 Posts
Well first give up on getting any support or decent support from GCC. Since Ruth left there is none there.

My Bengal cutter which I hadn't used in a while wouldn't allow me to change it over to 64 bit when my xp died. The buttons on the lcd work but just not for putting it in 64 bit mode.

I contacted GCC. No word for a month. THen I followed up with a nasty one. Got support. Did what they told me and still no go. I even redid an older computer with XP on it and still no cutter.
So I told the GCC support guy still not working after doing all he had me do.
His reply was GUess your cutter doesn't suppor that mode. WTF ?!?
Anyways I had a VmWare XP on my win7 64 machine and low and behold after installing the software it cuts now.
GO figure.
GCC support SUCKS
Good Luck
 

· Registered
Joined
·
1,028 Posts
Well first give up on getting any support or decent support from GCC. Since Ruth left there is none there.

My Bengal cutter which I hadn't used in a while wouldn't allow me to change it over to 64 bit when my xp died. The buttons on the lcd work but just not for putting it in 64 bit mode.

I contacted GCC. No word for a month. THen I followed up with a nasty one. Got support. Did what they told me and still no go. I even redid an older computer with XP on it and still no cutter.
So I told the GCC support guy still not working after doing all he had me do.
His reply was GUess your cutter doesn't suppor that mode. WTF ?!?
Anyways I had a VmWare XP on my win7 64 machine and low and behold after installing the software it cuts now.
GO figure.
GCC support SUCKS
Good Luck
Have you tried looking for a firmware update? My old mh from uscutter worked with windows 7 but not 8 until I did a firmware update from manufacturer. Keep in mind even if you do update does not guarantee it works with newer OS.

Sent from my SM-G900T using T-Shirt Forums
 

· Registered
Joined
·
2 Posts
Discussion Starter · #8 ·
Hi there,

thank you all for sharing your knowledge! After five days and a lot of stress, I got a call from a dealer technician who was on vacation... he tried (once more) all my checklist, and guess what - the Frankenxpert 24 is back to work...! Completely weird, bizar... we did NOTHING different, and when I asked him what did he do, he says "I don't know"!

I was able to update firmware in my previous Sable 60 years ago, following instructions and all... this time, I still don't get feedback from GCC - as you told me, I shouldn't expect anything but this - and my contact here in Brazil don't know what he did...

Nothing personal, but post-sales nowadays is a matter of life-and-death for companies who want to be taken seriously... in this aspect, Chinese companies are far behind... that is also the reason why other players keep their place in market... hope my next plotter is from a different AND reliable brand... thank you again!
 

· Registered
Joined
·
3,098 Posts
Have you tried looking for a firmware update? My old mh from uscutter worked with windows 7 but not 8 until I did a firmware update from manufacturer. Keep in mind even if you do update does not guarantee it works with newer OS.

Sent from my SM-G900T using T-Shirt Forums
firmware is already up to date but again if OS won't rec the cutter can't do a firmware upgrade.
 

· Registered
Joined
·
16 Posts
Hmm it doesn't appear you mentioned what exactly is going on with the cutter.

Is it just not responding to any jobs being sent?

I'm sure the machine is already in online mode, but perhaps the USB port isn't recognizing it.

A good way to test the connection is to open your Devices & Printers window and see if anything changes when you unplug/plug it back in to your computer while the machine is online.

Another thing could be the connection setup on your software settings, in GreatCut, go to the following menu:
Settings -> Standard Settings -> Output Devices
In this, click on the 3 periods, and choose change
as seen here: http://i.imgur.com/GXF5M2c.png

Verify that the device name and driver are set to the proper cutter and the USB/FireWire is setup with the cutters name on the dropdown selected.

Please let me know if these are all set up properly or if this resolves the issue :)
 
1 - 13 of 13 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top