T-Shirt Forums banner

1 - 18 of 18 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
...my f2000, White ink channel WH4 totally missing.
Just about one week ago, I do the white tube wash,
when wash done, every channel is fine,
but now, White ink channel WH4 totally missing...
do heave clean few times ---> WH4 still totally missing T.T
I'm out of warranty, tomorrow EPSON stuff will come to check my machine, may replace dumper or print head and pay lots of $$$...
I use f2000 for 14 month, this 14 month is fine, untill now T.T
 

·
Registered
Joined
·
328 Posts
Did you purchase the extended warranty? If not, let us know what the issue was and what it cost to repair. I would also try to get them to cover it as this is a common issue with these printers.
 

·
Registered
Joined
·
2 Posts
Discussion Starter #4
finally, today the epson tech came to testing my machine,
first power clean the white channel few times, not work, still missing whole WH4,
so we deside to replace the damper, fortunately, print head is fine ^^"
now all ink channel is perfect.

I don't purchase the extended warranty, so...

damper set (all colors): 5385 NT dollars ---> about $ 170

if replace the print head,

print head : 51554 NT dollars ---> about $ 1620

my total print count : 29xx (...two thousand, in 14 months XD)
 

·
Registered
Joined
·
319 Posts
welcome to the club, it sucks your out of warranty seems these epsons have issues with something but no one can pin point what it is. We have gone through 3 heads in 9 months 25k prints. im beginning to think we made a mistake in purchasing this printer.
 

·
Registered
Joined
·
27 Posts
I don't know what a good alternative would be, otherwise I would probably consider changing printers. Epson is getting on my nerves.
 

·
Registered
Joined
·
443 Posts
A bad damper after 14 months is pretty normal for any DTG printer. I don't understand the panic

Sent from my Nexus 5 using Tapatalk
 

·
Premium Member
Joined
·
2,443 Posts
Dampers are a definite consumable! Too bad Epson doesn't sell replacement parts direct. If they did I would highly recommend having a few dampers in stock. Of course this is all in hindsight since nobody really knew how the Epson would handle large print counts.
 

·
Registered
Joined
·
319 Posts
yeah what gets me is we cannot do installs ourselves, like dampers, heads etc, so having to pay the tech to install etc etc. is just extra $$$'

I personally will be moving forward with a printer that can fixed/diagnosed by myself instead of relying on someone else to fix it. Then we will sell this Epson if problems continue just one more time.
 

·
Registered
Joined
·
443 Posts
Dampers are a definite consumable! Too bad Epson doesn't sell replacement parts direct. If they did I would highly recommend having a few dampers in stock. Of course this is all in hindsight since nobody really knew how the Epson would handle large print counts.
yes you are right, unless epson can garantee a 100% working system they should allow those semi consumables like the sucktion cap and dampers for users to repair / replace themselfs. looks like i'm the next victim of the missing W3 W4 channels. nozzle check was fine, but after printing w3&4 missing.
i did a tube flush and that solved the issue for now. lets see if it will stay that way.
 

·
Registered
Joined
·
2,768 Posts
Not saying this is the issue for all those with very high print counts, say around 10K. But 2K in 14 months is not that high. I have found several users that had similar issues and just did not do the head cap cleaning as often or as well as they should have. I know some who have had problems did everything right, others have not.
 

·
Registered
Joined
·
15 Posts
yep same here, I had to have a head replaced 6 months ago because of 3&4 being out....been having issues with #3 & #4 every since then ..last week 3 & 4 went out completely again but I was able to fix it after 2 full tube washings & alot of heavy cleaning... today it's out again but tube washings & cleanings don't help at all.. called epson & the tech said he hasn't ever heard anything about problems with this
 

·
Registered
Joined
·
60 Posts
For the past 3 weeks my White Channel 4 has been dropping out completely as well. Had 3 techs come out so far. The first two techs were worthless. The first did heavy cleans and it worked but later that day it dropped out again. The second didn't even bring tools and he did the heavy cleans. I explained that bringing it back was not my issue it was once I did bring it back it drops out. My third tech who is knowledgeable replaced the capping station and it seemed to work for a few days. But then again it drops out again.

They have been very hesitant to replace the print head, I know it is not a clog in the head since I can get good nozzle checks but maybe there is some sore of circuitry that is not firing or possibly a leak in the fourth channel line that is not keeping pressure in the line.

If anybody has any thoughts I am anxious to get this issue behind me.

Thanks!
 

·
Registered
Joined
·
843 Posts
For the past 3 weeks my White Channel 4 has been dropping out completely as well. Had 3 techs come out so far. The first two techs were worthless. The first did heavy cleans and it worked but later that day it dropped out again. The second didn't even bring tools and he did the heavy cleans. I explained that bringing it back was not my issue it was once I did bring it back it drops out. My third tech who is knowledgeable replaced the capping station and it seemed to work for a few days. But then again it drops out again.

They have been very hesitant to replace the print head, I know it is not a clog in the head since I can get good nozzle checks but maybe there is some sore of circuitry that is not firing or possibly a leak in the fourth channel line that is not keeping pressure in the line.

If anybody has any thoughts I am anxious to get this issue behind me.

Thanks!

This is quite a normal scenario when you have a blockage on the F2000. Both times the head and dampers have needed replacing on my F2000 I was able to achieve perfect nozzle check then 1 or 2 prints later they were gone again.

The cleaning/flushing dislodges the blockage but as soon as you start printing it blocks again. Whether the blockage is in the dampers or the internal filters in the head both need replacing to resolve the issue. There is only one damper per 2 white channels so if there was a blockage or failure in one of the dampers you should be losing two white channels. 3 & 4 or 1 & 2.

It's disappointing that a techs have come out and all they've done is what you yourself can do by heavy cleaning. All that does is waste ink. Get them to replace the head and CRduct/dampers like they do with every other F2000 that has this issue, and get them to replace the white ink you've wasted messing around with cleaning.
 
1 - 18 of 18 Posts
Top