T-Shirt Forums banner

Urgent help needed please

1849 Views 12 Replies 2 Participants Last post by  soundbox3
I have just been notified my maintenance tank is full, and my chip re-setter fails to re-set it.

Without performing this properly the printer wont go into 'ready' mode.

I think that this will stop the hourly white ink cycle and thus may clog the tubes..

Is this true? and if so, how can I prevent the damage sooner rather than later?

It is the weekend now, so cannot get technical support.

1 - 13 of 13 Posts
It might be that the maintenance tank has come to the end of it's life and needs replacing, they're fairly inexpensive
A week later and I'm still having problems with this, I have tried 2 different chip re-setters and replaced the maintenance tank but I'm still left with the error..

"replace ink crtg"

None of the ink cartridges are indicated as full, however the maintenance tank status bar is fully black implying that it is this that's the problem.

None of it makes sense to be honest, any help appreciated.
If one of my ink cartridges needs to be replaced properly, how come it isn't indicated which one?
When you reset the ink carts or maintenance tank is the light on the reset chip slowly blinking?
Yes it is, and I can't seem to get any of the cartridges to go to green, just to red.

I'm considering whether all of the bulk ink system may need replacing, but would need confirmation before doing this as it will be expensive.

Through my printer status panel into my 'ink left' tab each colour lacks an indicator showing the ink left, it is instead displaying --% for every colour.

Is this normal?

Thanks for your input btw!
Not sure what you mean by saying the cartridges go from green to red. When I get a ink reset message, I just pull the cart out and plug the reseter in, if the light pulses then it's resetting, if it rapidly blinks then it't not set right on the cartridge chip.

You shouldn't have any need to go by anything the control panel says.
It doesn't go from green to red. It just never goes to green, it settles on red after blinking red for a while.

I haven't got the chip re-setter sold from resolute, so unsure whether this is the cause either.
As long as its a chip resetter suitable for the Epson 4880 then you should be ok, if it ain't then there's your problem
Well, it definitely is the right chip re-setter, just need to confirm whether the bulk ink system has passed it's sell by date..
I would reset every single cart and then see if you have the issue
This was purely down to not having the official chip re-setter, the epson one I had only worked for the maintenance tank. I needed the Resolute branded one for the inks to be reset.
1 - 13 of 13 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.