T-Shirt Forums banner

1 - 6 of 6 Posts

·
Registered
Joined
·
11 Posts
Discussion Starter #1
i am trying to embroider a port authority hcf safari hat. as soon as i hit start it make 2-3 strikes with the needle then the tread breaks. i am using a 75/11 needle with a polyester royal thread. anyone know what is wrong? do i need a different needle?
 

·
Registered
Joined
·
6,008 Posts
How old is the needle? Is there a burr on it that could be causing your problem? Change thread to a different needle and see if that problem still exists. Good luck.....JB
 

·
Registered
Joined
·
27 Posts
Definately change to another needle first to identify whether the problem will follow if you change.

The design itself may dictate the need to use a different size needle. Very small text might need a 70 and not a 75.

Lastly, don't discount the thread itself. If the problem goes away if you use a different needle position put up a new spool into the original position and see if it clears. Bad spools of thread are more common than you might think.
 

·
Registered
Joined
·
498 Posts
I know I may sound like an idiot for posting this, but it took me a while to learn there are two sides to a round needle. As I was changing needles on my 15 needle machine, I had slowly worked down to having 6 working needles. I had gotten lucky with those. So I guess what I am saying is to make sure you have the need in correctly and perfectly centered, which is hard to do.
 

·
Registered
Joined
·
1,107 Posts
Another thing to check it to make sure that the hat is hooped correctly. It may not be tight enough or too tight in the hoop and that will cause some breakage. Or even the backing could be a problem.
 

·
Registered
Joined
·
11 Posts
Discussion Starter #6
Just a rookie mistake or idiot mistake should i say!!! I took my bobbin casing out for oiling and never put it back in. After searching for an answer i saw my bobbin case laying on my counter, put it back in, and it sewed just fine!!!

Sorry for wasting everyone's time....
 
1 - 6 of 6 Posts
Top