T-Shirt Forums banner
1 - 11 of 11 Posts

· Registered
Joined
·
50 Posts
Discussion Starter · #1 ·
Hello, I bought a DTG Printer 3 months ago...have not printed more than 100 shirts so far (just getting started) was having problems with the white ink printing..been doing head cleanings daily...call the company i purchased from and was advised it was probably the print head...i drove to Tampa to spend 410.00 for a print head came home installed it and nothing...so i loaded the machine & took it to them on Monday...i've been advised everyday after alot of calls that..tues it was the ribbon, wed it was the capping station and thurs is now the motherboard...needless to say i am not happy...obviously they are test this & that until they find the correct part that makes it work again....the latest is no motherboards in stock...they are back ordered and who knows when they will be in...I did sorta go off on them on friday as i think i have a LEMON and i'm requesting a new printer...I have a huge event this coming wkend and no printer...not happy...does this seem "normal" that I should be having all these issues with a 3 month old machine??? i need some serious help as to where to turn....i've tried being nice, nice went to nasty :mad: thanks for any input or advise!
 

· Banned
Joined
·
499 Posts
IF you do not print daily when using white ink these things happen. What printer is it? It could possibly be the fuse on the motherboard that has gone, the only problem with that is those fuses are not meant to be replaceable. But if they are covering the Motherboard under warrenty you have no option, but if not and you or someone you know may be able to repair the one you have buy soldering in a replaceable fuse holder.
 

· Registered
Joined
·
50 Posts
Discussion Starter · #3 ·
thanks, i do use it ever day just for maybe a couple shirts tho....it is the HM1...i would have thought that they might take a working motherboard off one of their machines to see if that was the problem before making me wait who knows how many more days to get one in...atleast that would give them a clue if that was the problem..but..i don't think they have thought of that !!
 

· Registered
Joined
·
5,540 Posts
head cleanings are not enough..

How are your nozzle checks?? Do you have wims?

Is this a refurbished machine? Is the printer not printing or are the prints poor?

This is very odd to have to change everything in 3 months..
I mean everything..these are wear parts but some parts last more than 3 months.. (capping station suggestion is a year)

Heavy use is about 100 shirts a day these parts last about 6 months+ that's our experience

Is it our experience that Tampa (I am sure I know where you are going ) overcharges for parts and blames user error. Also, took over a week to diagnose every part on machine that is changeable and not covered under warranty.. Yeah this is normal.

Your situation is not!! Lets say I called one day and they diagnosed over the phone I needed over 150$ worth of parts.. I had my partner call back 15 minutes later at it was a wiper.. hmmm what had happened if I went and replaced 150$ of parts when it was not need and this wasn't the first or last time they did that.

This warranty I consider a "taillight warranty".. once your taillights are out of sight so is your warranty..
 

· Registered
Joined
·
50 Posts
Discussion Starter · #5 ·
yes i did the head cleaning and the nozzel checks every night after finished and every day i would start up...up until 2 days before i lugged it back to Tampa the colors were fine...after i spent that money for the new print head nothing worked...they emailed me friday and said that when i put the new print head in that there was a tooth missing in the ribbon that "I" must have done it when i put the new head it....the machine is brand new outa the box..and yes it has the wims system......i would love to do 100 shirts a day but i'm just starting up and i now have 3 events to get my name going on which amounts to 900 shirts and the 1st one coming here this weekend.... ugh! Tampa did say due to the problems (and them not knowing whats wrong) they would put all the parts under warranty....woops! and i do appriciate that, but I don't think i should have to be going thru all of this after 3 months..they are very slowwwwwwww at returning calls which i'm sure after last week they cringe when they hear my name on the recorder but damnnnn...a car mechanic can get a non working car back on the road in a couple days...dunno what their problem is? other than jerking me around :(
thanks for your help
 

· Registered
Joined
·
50 Posts
Discussion Starter · #6 ·
hey there, yes i do the head cleaning and the nozzel checks when i shut down at night and start up next day...up until 2 days before i took the machine in all the colors were working fine...with the old print head...was told it was the print head...being i'm new and duh..i drove over bought a new one,,,,came home and installed it..pretty easy....they now say that one of the teeth was missing in the ribbon and "I" must have done it when i was putting in the new print head...after putting it in nothing worked, no color no white :( thats when i had someone come to house, load it up and took it over there...The machine is brand new out of the box...just seems to me that they could take a motherboard out of a working one down there and test it and atleast know if thats the prob. or not? or take mine and put it in their machine...guess that would be common sense? :mad: they have told me that all the parts they will graciously cover under warranty...good thing...but w/all these probs...there are lemons out there...
 

· Registered
Joined
·
5,540 Posts
you are very lucky they are covered under warranty..this is very rare

you really need to know hands on how to replace that ribbon cable that has always been a thorn in my side. make sure you ask for all your old parts so that can compare for the future in case you do it again.

the ribbon cable is very fragile and is put in a very awkwardly which causes many problems.

We put in our new ribbon cable with damaged teeth with no problems we bent back straight buts thats our experience. It could have gone the other way..
 

· Registered
Joined
·
50 Posts
Discussion Starter · #8 ·
thank you....if I did or I didn't the ribbon was replaced and still nothing works...I do appriciate it that they are putting it all under warranty ..really...whats ticking me off is the time its taking them to do it all and jerking me around....they said they will have some answers on Monday...lets hope its good answers cuz at this point i'm over it all :(
 

· Registered
Joined
·
50 Posts
Discussion Starter · #11 ·
They finally called me this morning...they told me they had a loaner for me until my motherboard comes in....ask for my old print head n was told they trashed it..hmm i am now trying to set theirs up so i can get some work done :)
 
1 - 11 of 11 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top