T-Shirt Forums banner
1 - 8 of 8 Posts

·
Registered
Joined
·
30 Posts
Discussion Starter · #1 ·
I've just brought an Epson C110 and Rotech CISS setup. The printer works with its regular ink cartridges, I've tried pushing the reset button and jiggling the sublimation cartridges but the printer refuses to read the new chips.

Can anyone suggest something to help get my printer recognising the new cartridges?

Many thanks
Nic:(
 

·
Registered
Joined
·
1,555 Posts
Hi. Most CIS systems can be a pain to set up for the first time. I am assuming that you have got an 'ink out' light showing up? This is most likely going to get resolved with two solutions.

Most CIS consist of multiple empty cartridges with a 'piggy back' genuine cartridge and reset button. The first thing to ensure is that the metallic contacts on the cartridges are clean, as even grease from your fingers can cause problems. You also need to ensure the cartridges are fully clicked home as it is far more difficult to click a bank of cartridges into position, than it is with a single cartridge. What you assume is clicked into place, is not always so.

If you are still having problems after double checking the above, then it is likely you need to draw a little ink through the cartridges, as if you have even a small air bubble in there, the ink level system will interpret that as an empty cartridge. There is no loss of ink if you put it back into the bulk containers. Ensure you use a clean syringe for each colour though and take extra care that you put the right colour back into each container. You need to draw at least 5ml of ink through with the colours that are showing up as empty. Ensure that your air vents are free on the containers when you do this, or you'll create a vacuum.

Hope this helps.
 

·
Registered
Joined
·
30 Posts
Discussion Starter · #3 ·
I really appreciate that feedback. Thank you so much. I'll give it ago. Feels good to have some other options.

P.S Shame that they are a bit of a pain to get hooked up!

Cheers,

Nicole
 

·
Registered
Joined
·
2 Posts
Hi,

I have got the same problem with epson c110. I bought the css from superjetusa. at first I had to press the catridges really hard for the printer to recognize it.

I succeed to print a few nozzle checks but after a few head cleanings it prints blanks. totally blank.

Any suggestion would be appreciated very much. It's been a tiring 4 hour battle.
 

·
Registered
Joined
·
675 Posts
Having ink in the carts has nothing to do with printer being able to recognize the bulk ink system. When the printer recognizes the ink system it is reading the computer chips on the inks system. If the printer does not recognize the ink system after reseating it a few times, install the regular ink carts that came with the printer. If printer recognizes the regular ink carts., reinstall bulk ink system. If you continue to have problems, contact your vendor.
 

·
Registered
Joined
·
423 Posts
I've just brought an Epson C110 and Rotech CISS setup. The printer works with its regular ink cartridges, I've tried pushing the reset button and jiggling the sublimation cartridges but the printer refuses to read the new chips.

Can anyone suggest something to help get my printer recognising the new cartridges?

Many thanks
Nic:(
I have had similar problems with a CISS and ended up replacing the chips with ones from refillable carts that I had and it worked . Sometimes the chips are faulty and it is easier to replace the chips than the carts if all else fails for you .
 

·
Registered
Joined
·
675 Posts
Do not replace the computer chips on your new CIS. If the printer recognizes with the Epson carts, contact your vendor...your system should be under warranty.

If pressing the reset button does not reset system, check to see if there is a toogle switch underneath the reset button. If, so move toggle switch in the opposite position and turn printer off and back on. I highly encourage not to be replacing the computer chips on a new bulk ink system unless instructed by your vendor.
 
1 - 8 of 8 Posts
Top