T-Shirt Forums banner
1 - 7 of 7 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter · #1 ·
Hello,

I own a SWF/B-UK1504-45 Embroidery machine. When powering on the green power button no longer seems to work or light up. Also the contactor does not activate. I thought it was a bad contactor, so I replaced that. But it didn't fix the issue. Is it a bad button or possibly the transformer? Any help would be greatly appreciated. Trying to fix it myself. Thanks-Nick
 

·
Registered
Joined
·
9,410 Posts
I would start with the power supply in the control box
 

·
Registered
Joined
·
3 Posts
Discussion Starter · #3 ·
I forgot to mention, if I manually hold in the contactor the machine turns on and works fine. But the second I let it go, the machine turns off.
 

·
Registered
Joined
·
268 Posts
The problem is there is a open circuit in the machine. There is 3 things to check. First remove the covers near the emergency stop button and make sure one of the 2 wires isn't disconnected. I have seen this multiple times. Second make sure your emergency stop button isn't pushed in. If you remove the side panel where the switch is make sure everything is secure to the switch or all connections to the board are secured tightly. I am pretty sure one of the wires is lose or unhooked at the emergency stop button though.
 

·
Registered
Joined
·
3 Posts
Discussion Starter · #6 ·
Thanks to everyone that helped. We figured it out. It was a bad inline resistor going from the contactor to the green button. We replaced it and it works perfect now!
 

·
Registered
Joined
·
1 Posts
Thanks to everyone that helped. We figured it out. It was a bad inline resistor going from the contactor to the green button. We replaced it and it works perfect now!
Good Day. I am sitting with exactly the same problem. Is it possible for you to send me a photo wear this faulty part is situated. Or explain to me wear I can find it to replace the part.
Kind regards
Andre
 
1 - 7 of 7 Posts
Top