T-Shirt Forums banner
1 - 14 of 14 Posts

·
Registered
Joined
·
86 Posts
Discussion Starter · #1 ·
A week ago we had a 10028 error so we checked ribbon cables to print head they were good so we replaced the print head. When we started it back up the printer head would go thru the motions but no ink would come out. The print head had ink coming out of it when we did a cleaning. so we replaced the mother board and now we have no power to the screen on the printer.. Any ideas ????? thanks Doug
 

·
Registered
Joined
·
3,053 Posts
Does everything appear to be working as normal but zero ink from the printhead when you do a test print/nozzle check?

Have you used a syringe to draw inks through each damper?
Do you get any ink in the cap when doing a simple clean?
Have you disconnected the two pipes from the base of the cap?

Need more info to work out what the problem could be.

John
 

·
Registered
Joined
·
9 Posts
Everything is moving correctly,
We replaced the cap, the wiper and installed the new print head.
We cleaned all the lines, re-filled all the inks. Installed new dampers. Primed all the lines and dampers.
Did two F3 cleans.
We can pull ink manually into the capping station.
No error codes.
But just won't print anything?
Changed the mother board. USB cable.
All that's left is to change all the ribbon cables.?
Any other ideas.
The reason for changing the print head was because my red had clogged in the head?
Which is odd too.
But the red ink line itself was dirty.
 

·
Registered
Joined
·
9 Posts
Meter says it's good.
We did swap out the mother board too.
Just to make sure.
Even got a second meter, just to check the first meter.
Would any other fuses be a concern.
Everything was working great untill we had the print head problem. But we swapped that out, no error codes. And just won't print ink.
 

·
Registered
Joined
·
14 Posts
Hello,
Have you pulled all your hair out yet?
Have you tried prayer?
My NeoFlex demands a blood sacrifice every so often.

My bad inappropriate humor aside, I feel your frustration and my heart goes out to you. I've been right where your at with my machine, a good dozen times (sadly). I would suggest, putting the previous print head back on and observe. Even a old delaminated print head will fire ink. Of Coarse clean it up best you can first. Your looking to see if your print head is receiving the electrical impulses to fire the ink. And notice your spit station, it's dry or wet?

And another thing that helps.... let the machine just sit. It's just a machine there's nothing magical about it. I've learned to just step the hell away from "it" for a day or two.
Look on the bright side... it looks like you have a back up CA00 main board now.
Damn.... sure wish I had, had the funds for a new one of those when mine went out.
Beers are on Peter,
Clint
I'm here for ya man.
 

·
Registered
Joined
·
14 Posts
Just changed ribbon cables 0, 00, 000,
Checked all fuses.
F6
F2
F1
F8
F4
All are good.
Anything else?
Hi,
Another thing listen to Neo-Uncle John.
He's in the trenches every day. He knows what he's talking about. And what are the steps to initializing a new Epson main board?
I can't imagine you just drop in a new board and off you go. But then again I've never done that repair.
Clint
 

·
Registered
Joined
·
9 Posts
When the old print head goes in. We get the error code 00048.
We installed and had done that huge cleaning on Wednesday.
We let it rest untill thursday. That's when we realized it won't print.
On Friday.
We used our Neo sol printer mother board (as we don't use it much).
We swapped out all the Ribbon cables cables.
Checked all the fuses.
I've done the whole process.

My last shot in the dark.
The print head carryier?
It got a bit of red ink all over it. When we did the ink line clean.
The grounded prongs.
I have cleaned.
But there's that thigh gap that leads up to the encoder assembly.
I can't clean up in there.
Would this cause a bad ground for my print head.?
Just another idea.
I enjoy any feedback.
 

·
Registered
Joined
·
14 Posts
Sorry... I didn't know there was an 00048 error message. I have to look that one up. The print head carriage is really just a plastic holder to align the print head. Anything to do with the sensor strip, is just to position the print head on the rails and over the bed. Neither one of those is going to stop the nozzles from firing ink.
Oh, I have to ask, "were did the print head for the NeoTex come from?" The main board, thats nothing. But please tell me it didn't come from the NeoSol. I have a funny story about textile ink and solvent ink, and it all started with the LCD window on my printer going out.

One idea I had was check the 7,8,54 (not 9) flat ribbon cables connected to the main board. Those 3 cables send the info to fire the ink. I remember the 54 cable on "my board" did a short reroute to another sub-board on the main board and then on to the 9 cable then out to the 0,00,000 cables. I can only say if I had followed the nice pictures in the Epson manual, I would have done it wrong.
Last thing, there is no reason this can't be a software issue. It can't hurt to reistall the printer & NeoRip Pro. My God! I can't even think what's left that you can replace. At the very least up date the firmware and NVRAM.
Clint
 
1 - 14 of 14 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top