T-Shirt Forums banner
1 - 4 of 4 Posts

Registered
Joined
157 Posts
Discussion Starter · #1 ·
Howdy guys...I got some gamma block to do some safety yellow tees, I lowered my off contact but had terrible results using a 156 screen.

The waterbase is soooo watery lol I'm not sure what I am doing wrong. Thought I followed the tutorials correctly.

The ink seemed to watery, had a hard time controlling it, kept the screen flooded....just never got a good stroke , it was a mess hahaha

And I also learned all emulsion is not created equal lol...did not know it's a different emulsion for waterbase 馃檮

Thank you
Markus
 

Registered
Joined
54 Posts
Welcome to the wonderful world of water base printing. I've been using water base from the beginning and found there are some emulsions that work with both.

There could be a number of reasons you're not getting a good coating. It could be, you're not using enough pressure with the squeegee when you print. I too have had a problem like this but it's only with 1 screen for my shirt line. I've actually started printing from the side for this shirt and it's allowed me to get a good print. All my other screens I don't have that problem just the 1. I also push my squeegee instead of pull, I've found I have better control of the squeegee and pressure that way. Don't be afraid to try other ways of doing things, you may be surprised when they work for you.

I hope this helps you.
 

Registered
Joined
7 Posts
Oh man! Safety Yellow tees are brutal to print without some kind of dye migration. I wouldn't even bother printing waterbase on them, it's too thin. basically every color except black needs to be underlayed on safety yellow or else the ink will color shift thru the dryer.
 
1 - 4 of 4 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top