T-Shirt Forums banner
21 - 25 of 25 Posts

·
Registered
Joined
·
6,428 Posts
Thanks guys for the support, and you bring up an interesting point about the c88+ being new, i purchased it from a big box retailer in the box off the shelve, but who knows the shelf life especially since its discontinued right? I did some research on the forums and found a few threads of people have the same issue with the C88+. I guess there was an overspray issue with the c8x models, even using their OEM ink. So i think i'm going to purchase a newer version. What are some affordable, yet good epson sublimation printers that you guys would suggest?
I'm using a WF1100 which is no longer available. The WF7010 replaced that but I have no experience with it, Gordon has one of the 7XXX models.
 

·
Registered
Joined
·
2,256 Posts
The 7010 is a good printer for its price, though there are some issues you have to get used to. One, which apparently only a few people have (or notice), is that on Plain paper settings you can't reliably print to the ends of the page without the printer prematurely ejecting the paper before the last passes of the print head. I had hoped the recent firmware update would fix the problem, but it didn't. It causes a banding at the end at the last 1/2" of the print. The problem doesn't occur if you don't print near to the edges of the paper.

I have two 7010s, and it behaves the same with both.

One is a pigment printer, the other sub. Both are CISS. I'm thinking I might convert the sub 7010 to cartridges, so I can go back and forth. Right now I'm doing more pigment printing (also laser on synthetic paper). I have a Workforce 30 for the gruntwork sub printing I do. It's only letter size, but most of what I do at the moment fits.

Another issue is that the 7010 has a tendency to "forget" its head alignment settings when you do a cartridge reset. It doesn't always happen, but after resetting, run a quick test print to make sure there aren't any banding issues. This MAY have something to do with the particular reset chips that Cobra sells, or it could be a printer issue. The recent firmware update was supposed to fix something related to head alignment, and maybe this was it.
 
21 - 25 of 25 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top