T-Shirt Forums banner
1 - 19 of 19 Posts

· Registered
Joined
·
54 Posts
Discussion Starter · #1 ·
I am so happy to upgrade my computer to Leopard only to find out later that I can not use my Epson Stylus Color 3000 printer. Does any body have any suggestions? Please let me hear from you :)
Many thanks!
 

· Premium Member
Joined
·
4,536 Posts
Leopard uses Gutenprint for outdated printers. Go to Apple Menu / System Preferences / Print and Fax / Click the Plus sign to add a printer / Click on the Epson 3000 that should be listed under your default browser or however your printer is connected / Choose Print Using / Select a driver to use / in the search box just type 3000 / Choose Epson Style Color 3000 - Gutenprint v5.1.3.

If you can't find it, you may need to update your Leopard by going to Apple Menu / Software Update. If that doesn't work, you may be able to find the drivers on your Leopard disc. It's been so long since I've upgraded I don't remember if I had to add them separately or if they were added upon install.
 

· Registered
Joined
·
54 Posts
Discussion Starter · #3 ·
Thank you for the help. I am a slow learner. May take me a while but I couldn't do it with your help. I did see the Epson Style Color 3000 - Gutenprint v5.1.3.on the list when I seleted one my other 2 printers. At this point I need to get the 3000 to show up on the list. Start from the beging. I look forward to working this one out. I really enjoy having this forum.
Many thanks. I will let you know when I succeed.
 

· Premium Member
Joined
·
4,536 Posts
Thank you for the help. I am a slow learner. May take me a while but I couldn't do it with your help. I did see the Epson Style Color 3000 - Gutenprint v5.1.3.on the list when I seleted one my other 2 printers. At this point I need to get the 3000 to show up on the list. Start from the beging. I look forward to working this one out. I really enjoy having this forum.
Many thanks. I will let you know when I succeed.
How do you have your printer connected?
 

· Premium Member
Joined
·
4,536 Posts
Yes in the hub. Hm,,, I will put it in the back of the computer. Thanks!
I attached three images.

Image 1: Print Setup Screen, notice the various methods of locating a printer. Most of the time, the default will locate all your printers, but older printers may require a different method.

Image 2: Looking under More Printers

Image 3: Selections, notice Epson TCIP. When you said hub, I am not sure if your printer has the ethernet card, if it does, you may need to choose this option to find it.

Just browse through these and most likely you will find your printer.
 

Attachments

· Registered
Joined
·
54 Posts
Discussion Starter · #7 ·
I have the 3000 listed in the queue. I can see the epson Style Color 3000 - Gutenprint v5.1.3.on the info list as you said. I can print out, but I can not change the resolution and check the mirror box. Also on the image I get banding and need to change the resolution and hopefull it will go away. When I select "layout" as I do when printing on my C88+ and C120 to set the quality and mirror image, it goes away and I get an error box saying PS has quite unexpectedly. My computer is new and I don't know if it has an ethernet card. I can look it up and get back to you. Also the 3000 is comunicating with my computer via textedit and printing. So I do know that much. Thanks again for all your help. I really need it. Do you know if there is a cable I can use?
 

· Premium Member
Joined
·
4,536 Posts
If you are connected to the printer, then you don't need to worry about any other type of connection. You may need to adjust some settings within the print dialogue box to avoid banding, etc. You may have a drop down menu with printer features available. I don't know hardly anything about the 3000, but within those settings, it should fix your issues.
 

· Registered
Joined
·
3,506 Posts
to fix the resolution and the mirror option: that's done in the print dialog box. you have to select output to get to those functions. (i'm trying to think off the top of my head but i had the same problem..........not realizing that there were more options. just take your time and go through all the functions.) -peace.
 

· Registered
Joined
·
54 Posts
Discussion Starter · #11 ·
Hi and thanks for your help.
I took the printer in for new heads, ouch! and that will get ride of the banding I hope! I can flip it in image file. I talked to Epson 4 time and they said NO drive for Leopard and so I can't change the res for the printer. Auto is 360 res and I will have to work with that for now.
Many thanks,
Diane
 

· Registered
Joined
·
3,506 Posts
yikes.

yea i just checked the epson website and they only have drivers up to osx 10.4.

it stinks that a printer that is only 5 years old is cast aside when operating systems evolve but i've had the same problem more than once over the years.

i have a scanner that i love but umax (the manufacturer) stopped supporting it after os9. so i restart my g4 into classic os just to scan. save the files and then restart and open/edit in my osx 10.2.8.

you could do the same instead of buying a new printer. i know it's more time consuming etc. but hey.

and this is a little late but i would have restarted into classic and used the epson printer utility to clean the heads and align them. sorry. hope everything works out. -peace.
 

· Registered
Joined
·
54 Posts
Discussion Starter · #15 ·
Thanks for trying to help me. It's really hard to go back to classic on my old computer when I have a new 22" computer and up graded from 7.0 PS to CS3 PS. I used the utilities and the alignment in leopard (I just can't change the res.) and the banding was still there. I just hope the banding goes away with the new heads. One of the reasons I like the Epson 3000 is it uses 4 inks. I don't like spending more money on inks with the new wide format printers 8 inks. I just am not that big of an operation. I should get my printer back this week. Wish me luck!
 

· Registered
Joined
·
19 Posts
Hi. I've been looking into this for a while. I reinstalled tiger after messing with the epson 3000 driver on leopard. The gutenprint drivers are TERRIBLE.. Do not bother trying to output films with this driver. I even tried using the trial version off ACCURIP to get the printer to output solid films with gutenprint driver... no luck. You need to figure out a way to use the epson driver...

I found a forum where someone seems to have had success.
I'm not going to try it till I here of another success story.. can't afford to waste time with this again.

maybe give it a shot and report back.. I'd be interested to here how it goes.

** solution is at bottom of the page**

Leopard problem with Epson 3000 - Tech Support Forum
 

· Registered
Joined
·
54 Posts
Discussion Starter · #17 ·
Thank you so much! I knew there were others in this same situation. It looks like where we want to be with the 1440 :) I am eager to try it out after the holidays. Many, many thanks. I will stay in touch and let you know how it goes. If you try it before me please let me know what you think.
Super thanks,
Diane
 

· Registered
Joined
·
19 Posts
SOLUTION!! Re: Leopard OS X does not have a driver for Epson 3000 printer?

Turns out the gutenprint drivers are not so bad after all. Here are the settings to output nice films on an Epson 3000 using OS leopard. The saturation was the problem I was having with the Gutenprint driver and here is the adjustment... hidden in the print menu.

You will need to download the latest gutenprint driver here.

Please share this! I've spend a lot of time trying to figure this out!









 
1 - 19 of 19 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top