T-Shirt Forums banner

1 - 9 of 9 Posts

·
Registered
Joined
·
7 Posts
Discussion Starter #1
Ok here's the story ... bought this printer used about 9 months ago & have yet to get 100 shirts out of it! The following parts have been replaced once(1) or twice(2) since purchace:
Print heads (2)
capping station (2)
wipers (2)
pads (2)
carriage assembly (1)
Ribbon Cables (2)
Bulk Ink Assy (1)
Encoding Strip (2)
Here's the problem I'm having now:
Was printing fine, just quit printing white ink & I was low so I ordered more, shut it down & cleaned it up. 5 days later filled all inks & started to print' then white ink quit, then all ink stoped coming out. Bottles good, lines good, cardtridge good, Shut it down, took it apart, checked ribbon cables OK, Syringed print head .. OK... Back together, (No I didn't get it wet) goes thru all the motions, head cleaned ok with both manual button & computer command in the printer/preference/maintance (indicates cpu talking to printer) Pumps ink in capping station during cleaning. Will NOT print ink, not even nozel check, I take that back I got 1 nozel test , about 50%, out of 6-8 , I think it was #3 test, all the rest nothing. In the pages to printer/output queue/dtg rip pro it shows it printed it but printed "0" bytes, which is correct, but it goes thru all the motions just no ink! Could the print driver(s) cause this? I've usually been able to find a fix on here but this one has me stumpted. I considered the motherboard which I don't want to replace on a whim, kinda pricy, but why would I get that nozzel check? Anybody know where I can get a motherboard tested? Are they all the same Epson 2200 I mean? Or is it a software issue, even the nozzel test were showing in the ouput queue, showing printed w/ 150kb. I don't really want to reinstall RIPPro, not real usuer friendly & can cost you a validation... You only get three, I got 1 left.
Any HELP!!! would be greately appreciated. I had absolutely no idea you had to be technician in order to operate one of these machines. WOW! What a lesson in life!
thanks
BJ - Stitch & Awl
 

·
Registered
Joined
·
232 Posts
Try sending a test page to the epson driver and see what really happens.
I made an epson 2200 diy dtg and this error almost drived me crazy, it happened 2 times once a week ago and once yesterday. Yesterday it happened after i sent 2 passes of white at 720 and 2 passes of color at 720
Test page works from all queues but when i try to print from the rip interface everything goes as it should be but NO INK is coming out of the head while printing
I reinstalled the rip but it didn't help
Only formatting the hard drive solved the issue for me
I contacted support and still waiting for a reply.
 

·
Registered
Joined
·
1,286 Posts
It sounds like you have multiple problems going on there.

When you power it off, then back on, do a head clean then a Nozzle check, how does it look? Are all the colors there? Are all 3 white channels there? If so then you ruled out some clogging and starvation issues.

If not, you have clogging, starvation, ink level or a bad print head.

If the nozzles are decent, then try to print again, color only. Does color on a white shirt work? If so, then try to print on a dark shirt. Ensure that your white is not pure white #FFFFFF in RGB mode, should be 1% of C / M or Y.
 

·
Registered
Joined
·
7 Posts
Discussion Starter #4
Complete power down,cpu & printer several times, no print on Nozzel Test or anything else, capping station shows railbow (all colors) in head cleaning, just no print. Syringed thru print head, no clogging. Bottles, lines, cardridge's full just doesn't print any color on anything.
 

·
Registered
Joined
·
5,275 Posts
you can call iproof and get one or two validations back.. explain you are having problems.

Did you use Rip Repair? doesn't require reinstall

what Rip Version are you using ? V04? do you have the latest updates? check with SWF?

When you got it did you see an actual shirt being printed? Did you buy it used from a private party /or SWF?

Why have you replaced these parts??
 

·
Registered
Joined
·
7 Posts
Discussion Starter #6
Used machine, bought entire business from private party & yes the did print a tshirt when we bought it.
Head was damaged (I think) from trip frm Fl. to Texas. Then I clogged up the second one thinking running head cleaning (with ink) was sufficient, live & learn. Started having various start up & printing issues so we replaced everything, some of it twice. Not familar with RIP Repair. I contacted SWF Mesa in FT Worth, right after we bought equiptment who were no help. They said since they had made nothing off me or this machine the were not required to offer any assistance. They did sell me a set of defective cables (thats why they were replaced twice) and offered a used carriage assy at twice the going rate. When I asked why so high priced they informed me that parts for equiptment that didn't come from them is marked up.
Do you have a contact @ SWF that might be able to help give advice. I realize that peoples time is valuable & they don't owe me anything, I just need some guidance & can't afford a motherboard on just a maybe this will fix it. I might put an old print head (partially clogged) just to see if I can get a nozzel check, what do you think? The Rippro is Ver.03. How do I go about upgrading? Is Rip Repair part of ver4
thanks
BJ-Stitch & Awl
 

·
Registered
Joined
·
2,497 Posts
I contacted SWF Mesa in FT Worth, right after we bought equiptment who were no help. They said since they had made nothing off me or this machine the were not required to offer any assistance. They did sell me a set of defective cables (thats why they were replaced twice) and offered a used carriage assy at twice the going rate. When I asked why so high priced they informed me that parts for equiptment that didn't come from them is marked up.
While I can't help you with your problem I do have to say that the response you got from SWF Mesa would be enough for me to never buy a SWF/DTG machine ever, it was totally uncalled for.

I hope someone here can help you.
 

·
Registered
Joined
·
5,275 Posts
Not familar with RIP Repair. I The Rippro is Ver.03. How do I go about upgrading? Is Rip Repair part of ver4
(rip repair) its right at the start up.. V04 is the new and latest version. We never had v03 so not sure they major difference. I don't think there is cause to upgrade right now.

I want to say its the fuse on the motherboard. If you can ink fill and all the colors show you do not have a clog or at least its not showing a clog. An ink fill literally pulls the ink from the lines through the printhead into capping station.

The motorboard fix is an inexpensive fix.
I do not advice you do this yourself unless you are a soldering pro. The directions are for a T-Jet which is the fraternal twin of the Kiosk.

You are basically making a external fuse holder (now T-Jet 2 made these a standard since people pop their fuses all the time because the ribbon cable got wet or basic cleaning caused the fuse to pop) YOU ARE NO REPLACING THE FUSE you making jumper cables for the blown fuse and the cables are connected to an external fuse holder with a fuse.

People say you can go to Radio Shack and get these parts ~> we have 8 RS within a 5 mile radius and they do not carry them. We found these parts for less than $30 at Grainger. If you know someone who can solder the wires (18-22 gauge) to the fuse on the motherboard bonus you saved some money.. but you need to use a professional.

Good Luck!!
 
1 - 9 of 9 Posts
Top