T-Shirt Forums banner
1 - 5 of 5 Posts

·
Registered
Joined
·
7 Posts
Discussion Starter · #1 · (Edited)
I bought this press used. Someone has painted it and I do not see a name anywhere on it.
It was in pieces and I have tried to put it together a few ways but it doesn't seem right. I have cleaned out all bearings with brake cleaner and re greased them.

I have a bearing and a large washer left. I do not know where the bearing goes? Should i place it under the rotary arm or under the printing arms?

I have attached a drawing I made up, if a visual helps.

any one familiar with this setup that can give me some input, I would be grateful.

[URL="
[/URL]


I have tried several times to post this pic, It will not work.
 

·
Registered
Joined
·
115 Posts
If you could possible take pics of the machine and its components that would help. You may need to implement parts into it in order for it to work. It will take time but you will get there eventually

Sent from my GT-I9300T using T-Shirt Forums
 

·
Registered
Joined
·
419 Posts
I am djb28 .I created this name and decided I wanted to use my business name instead. I dont even know why my pc held on to thst name when I logged on.anyway I have been real busy trying to get my shop open. I will get pics in the next day or so. I have ordered two new bearing plates. They are just 12 inch bearings and I think the ones on there he ruined. A little bent and after re greasing they dont spin well. Its not an expensive unit that is pretty obvious but I would love to get it going.

Thanks for your responses and I will get the pics. Where do I load them to? I use to link to imageshack but they are now charging. The last place I used above.. I can not get it to post properly and it doesn't even show it works in preview before posting.
 
1 - 5 of 5 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top