T-Shirt Forums banner
1 - 3 of 3 Posts

· Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
i just recently bought a bn20 second hand, i think, and replaced everything replaceable

dampers wipers and captop.

it boots and initializes properly, no issues.

only problem i found is that no ink is printing out. did a head soak, no changes
 

· Registered
Joined
·
781 Posts
i just recently bought a bn20 second hand, i think, and replaced everything replaceable

dampers wipers and captop.

it boots and initializes properly, no issues.

only problem i found is that no ink is printing out. did a head soak, no changes
The heads are replaceable.

If you are sure everything else is working, and you have tried normal, medium, and powerful head cleanings and it is not getting ANY ink to the head. You could try wipping the head (dabbing really) with a cleaning fluid soaked cleaning swab. If your not getting any ink after a head soak then it sounds like it is a dead print head, board, or bad cable. If your not getting a good seal from the captops, this will also cause no ink to come out.

We bought out a shop a few years ago and in it was a dead Roland sp540v that did not fire any ink... over the coarse of about 3 days we got it back to 100% on the yellow, and magenta head. The cyan channel 100% and the black to about 98% using a dabbing method and mostly medium cleanings with a few powerful ones thrown in. You WILL use a lot of ink FYI.

Also another way would be to try to perform a head wash, but you will need cleaning cartridges and if the ink is not flowing it may not work.
 

· Registered
Joined
·
1 Posts
Discussion Starter · #3 · (Edited)
Thanks for the insight Amw.
I think it's more among a dead prinhead, board or cable because the printhead before was damaged and I couldn't afford a new printead but I idling on Ebay one day and saw someone selling 8 printheads for cheap. I took a chance in buying them. the printhead installed is one of them.
I carefully did a manual head soak by submerging the printhead about 1-2mm in a bowl of cleaning solution before installing
Btw, can the printhead be install incorrectly because I realized that it has quad inserts on both sides and could you update me more on the " bad cable " part
I
 
1 - 3 of 3 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top