T-Shirt Forums banner
1 - 1 of 1 Posts

296 Posts
Discussion Starter · #1 ·
So, I have an epson R1800 printer that is not working right now. I was printing with it, and things were going good then a black outline I had started to get streaky, but everything else was fine. So, I DID go to the printer utilities where I ran the head cleaning and all of the other things. The printer started printing loads of ink onto the printer.

Did the cleaning again and now nothing is coming out. There is an occasional black ink spot that comes out. I have tried the cleaning a few more times. I have let it sit for a day and tried it again. Then ran it and nothing came out.

I called the local computer store they priced a new head for the printer and I am not about to put the money into it.

Could everything just be clogged and is there anyway I can clean it out manually? I am willing to try anything.

1 - 1 of 1 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.