T-Shirt Forums banner

1 - 4 of 4 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
Hi i am very new into silk screen and i have been surfing the net for instructions. i have tried the photo emulsion method yesterday and everything went fine except for one part. After i spread the texilac paint on the screen, used a squeegee to print the image on the shirt and lifted up the frame, the ink smudged. I do not know why this is so. Can anyone help me on this? Thanks so much! All i need is a evenly spread painted image on the shirt.. mine seems to be uneven after i lift the frame up.
 

·
Premium Member
Joined
·
10,512 Posts
Could be lots of different things causing that. I'm also new to printing, so you may want to wait for a better response from those on here with more experience, but my first instinct is that maybe you're not removing the excess ink? Are you making a clean pass of the squeegee without ink before lifting the screen? (i.e. 1. flood, 2. firm print, 3. clean pass to remove excess ink).

Other potential problems would be that your screen isn't braced so you're moving it when printing or removing it, or that your ink is too thick.
 

·
Registered
Joined
·
2 Posts
Discussion Starter #4
no im not using a spray mount. i think i will try that. one more thing.. is it a must to use hinge? basically i just place e screen onto the shirt and use a squeegee to spread the paint.. after which i lift the frame up.. thats all. am i missing something?
 
1 - 4 of 4 Posts
Top