T-Shirt Forums banner
21 - 33 of 33 Posts

· Registered
Joined
·
1 Posts
I have the same problem with my printer stuck in the auto maintenance mode. All 8 of the lights on the board are illuminated. I called anajet and they said it was either a blown fuse going to the the motherboard or the motherboard itself that was bad. Does anyone have any idea of where this fuse is located? All I could get out of tech support was that it was soldered in. They want $1180 plus shipping for a new motherboard and if I have to ship the machine back to them Im looking at another $500 in shiping costs each way. I replaced the print head first when they said it was the print head. If anyone has to replace their printhead the print head is the same head that is used on the Epson R1800 printer. I got a complete printer off of ebay for $135.00. Anajet quoted me $950 for the same thing. Any help would be great appreciated as I am currently dead in the water for now. Also is there any other motherboard out there that will work on the machine?
 

· Registered
Joined
·
187 Posts
update-- for what its worth i did find out that the red lights on top left to right labeled 1 thru 8, coincide with the individual chips left to right in the carriage .for example if you cover the first chip with tape the r8 light lights up.. so what ever the function of the third chip is what is failing and causing the auto maintenance loop. i checked all my fuses and cleaned all of the ribbon cables. there are 8 chips 8 lights on top and 8 ink carts so im assuming that our problem is somewhere else in the printer
 

· Registered
Joined
·
216 Posts
Ok this has happens to me a few times, and after no help from Anajet except to buy parts at huge prices. What you need to do is use a cleaning swab with alcohol or circuit board cleaner is good and clean the contacts on the chip holder contacts, strange but ink can get in there when your installing the dampers, do it three or four times, look in there with a light and check it good. If you still see the light try a good chip holder, if still no luck post a photo here and see what we can do. Trust me it will work
 
21 - 33 of 33 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top