T-Shirt Forums banner

Epson R3000: Power light and ink light blinking simultaneously

2152 Views 5 Replies 2 Participants Last post by  gullprint
Espon R3000 shut down in the middle of printing. We tried turning it on a few times, and it would shut down after a few seconds, then the light began blinking. There was no message on the screen.
Now, when I press the power button, both power light and ink light flash simultaneously and the screen is dead. So the problem seems to be getting worse.

Does anyone have any ideas? Please help.
1 - 6 of 6 Posts
Unplug the unit from the power source and check the CN1 and CN2 flat cables to see if they are connected properly to the front panel board. Always unplug the printer while working on the printer. Have you done any work on the printer prior trying to print?
Thank you for your response. Yes, we worked on the printer for 2 years. The CN1 and CN2 flat cables seem to be ok. We took apart the printhead to check the ribbon connections. We see some evidence of ink on the printhead, so maybe it caused the short?
How would we go about checking the fuses on the mainboard? Is there a thread/instructions/pictures on how to locate them?
Thank you so much again.
So we have replaced the mainbroard, flat wires, and power supply. The printer is Ready now, however, since it's a Spectra, it's not connecting to the software.
I assume meant Rip software? I am using called PowerRip ModeOne for my R3000 UFO conversion.. Also can be used just as a R3000 Epson with just regular inks...
Yes, Spectra Rip software. We ended up putting back the old mainboard and thankfully it worked, so probably it was just the ribbons that caused the problem.
1 - 6 of 6 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.