T-Shirt Forums banner
1 - 1 of 1 Posts

· Registered
2 Posts
Discussion Starter · #1 ·
Hi there I'm hoping somebody maybe can tell me what to do when the CIS cartridges aren't being recognised by an R1900.

Printer was replaced today by Epson after 3 months because the roll feed went mental. Now when I try to replace the carts the first four cannot be recognised.

I've tried reseating a few times and they're all clicking nicely into place so I'm thinking maybe the chips have got fried somehow and I'm just grasping at straws.

As you can see from the pic there are cartridge reset buttons on each block of four cartridges. Holding them down for 5 seconds hasn't worked but I wonder what are the two small springs/coils on the bit of circuit board that sticks up to the right of each reset switch?

Also somebody replying on another forum to somebody with a similar problem said "reset the ink levels on the printer". I'm not sure if that just means use the reset chips on the cartridges or something else. If it's something else I'd sure like to know what.

Thanks and thanks again to anybody with any ideas. Epson took two weeks to arrive on their 48 hour service call out and I'm already backlogged and its the weekend so no chance of getting any help from Visi-Sub until Monday.
1 - 1 of 1 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.