T-Shirt Forums banner
1 - 7 of 7 Posts

·
Registered
Joined
·
39 Posts
Discussion Starter · #1 ·
I bought a c86... was using it for a while... Then I added a cis system to it and all hell broke loose! The cyan was clogged... I wound up buying a c88 because I love the way my prints were coming out. I used the same cis system stupidly... and now i got another clog... Any suggestions??

Also... lately my printer has been printing weird... at the end of the picture... it'll mess up on the corners.. It'll smear black ink all over the corners... also it'll bend the corners and put ink on the back of the paper too...

ANY HELP WOULD BE GREAT!!!

Thanks in advance:)
 

·
Registered
Joined
·
4,766 Posts
Yep.. but it is also the paper I bet. Are you trying to print to the end of the paper. Your not using epson cartridges are you? I get this a lot. When the print heads go over the end of the page and because it may be slightly curled it is clipping the heads and splattering the ink. here are a couple of things to do. First if your going to do full pages then set printer up for border-less printing. The other thing try printing a few pictures smaller on the page and see if it does not stop. What happen there is the ink has stopped pumping be for it gets close to the end of the paper. Lots of inks not epson made will do this. I am using one now and I get the same thing. Sometimes I have to change the cartridge, especially black.
 

·
Registered
Joined
·
39 Posts
Discussion Starter · #4 ·
I have a constant ink system hooked up... this morning i went to staples and bought 4 genuine epson inks... 70 bucks... I thought it might help the problem... but its the same...

I'm trying to print out the pics with the border... it was no problem before now it seems impossible. I have an hp psc750... one of those all in one printers with the scanner and copier...

I never had problems with it... it just wastes a lot of ink.. i liked the idea of the separate ink cartridges...

I am really dissapointed w/ epson :-\
 

·
Registered
Joined
·
4,766 Posts
You have to look at the viable as to what you did before VS what are you doing different now. There has to be something changed in your printing method to cause the problem. One might be the hook up of your CIS system. By the way where did you get. Not all of them are great. I have seen a lot of people have problems with them. Try back tracking. By the way get hold of John at New Milford Photo and ask him about the Pigment ink that he sent me for testing. I am using it and I like it. The cost is I believe about half of Epson. It is called Premium Imaging products. Be sure to stress pigment ink.
 

·
Registered
Joined
·
39 Posts
Discussion Starter · #6 ·
I bought my cis from ebay from "vtechplace" the cis was working pretty good for about 2 months... thats probably the problem. I bought it for like 60 bucks...
I buy my paper from new milford photo as well... they have great paper and the price is pretty good also...

I got another question for you, cause u seem very knowledgable. I have been buying paper from new milford photo for a while now... they usually send me the paper that has the single blue line in the back.... then one day they sent me a different kind of paper that had a blue grid. That paper was wonderful! It had a glossy shiny look, and it looked more like a rubber. Do you know about this paper and where i can get some???

Thanks for the responses
 

·
Registered
Joined
·
4,766 Posts
I just made the switch to the blue grid because I did not like the blue line. Buying from Coastal. But if john has it now I will I thought the old paper was too hard. If John has it now I will buy from him.
 
1 - 7 of 7 Posts
Top