T-Shirt Forums banner
1 - 6 of 6 Posts

· Registered
Joined
·
415 Posts
Discussion Starter · #1 ·
Tonight my Epson stopped printing most colors. I did a nozzle check and only blue shows up. I did a cleaning a few times but it did not help.

I removed the print head and everything came out clean. Re-installed and still wouldn't print.

What else can I do?
 

· Banned
Joined
·
73 Posts
if one colors works that means fuses are in good condition, if print head is cleaned, i think cartreges is clogued.
or maybe pump and capping station problem, when printer cleans print head see well pump dose work or not.
 

· Registered
Joined
·
8,278 Posts
Pull the plugs on the cartridge end portion. Use a syringe to pull up the ink from CISS. Also try removing the filter on the tanks. If these become plugged it will not allow ink to flow. I replace mine every year now. For a few bucks not worth messing around. It is also possible that the sponges in the cartridges are plugged and in that case replacement is best option. Trying to clean could result in sending large particles to the printhead rendering it useless permanently.
 

· Registered
Joined
·
7 Posts
I am going to order a whole new CISS system. I took it out of the old one and put it in my Epson 1400 at the shop. I got the same results. So something must be clogged up pretty good in the cart. It just sucks because I have a job to do.. I will try the girlfriends, canon..and maybe I can print a couple to make it dark
 
1 - 6 of 6 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top