T-Shirt Forums banner

1 - 18 of 18 Posts

·
Registered
Joined
·
6 Posts
Discussion Starter #1
I have K2 I can print on the printer bed no problem. But if put a t-shirt or even a peice of paper in the machine it goes through the motion but no ink comes out.

I normally use corel x4, I've tried printing directly from the rip pro and also photo shop.

No matter which software it runs through the motion but doesn't put down ink on a shirt.

But if I take out the shirt and run it it will print on the metal.
 

·
Registered
Joined
·
2,497 Posts
:welcome:We're glad to have you aboard!

That is a strange problem, hopefully someone will have a answer for you, how did this problem start, has the machine sat for any length of time?
 

·
Registered
Joined
·
1,286 Posts
K2 as in Kiosk?

That is very strange as most machines would not be able to tell if you had a t-shirt vs only a platen in there.

here is a dumb question. Are you trying to print on a black shirt that is not pre-treated perhaps? If so, the ink would look almost invisible.
 

·
Registered
Joined
·
11 Posts
If the printer "prints" but no ink comes out the first thing to look at is your head cables,

Check first that the connections are good, Take loose the printhead and look closly at the metal connections on the cables that theere is no ink on theese,
If you have a burned mark or ink here probably the Epson mainboard is broken, Or actually one tiny fuse that is welded on the board
 

·
Registered
Joined
·
6 Posts
Discussion Starter #6
I printed the checks on the bed and it worked. After trying to print on shirts not working I took the shirt off so I wouldn't waist the shirt. So then it printed.
 

·
Registered
Joined
·
9,194 Posts
I printed the checks on the bed and it worked. After trying to print on shirts not working I took the shirt off so I wouldn't waist the shirt. So then it printed.
what color shirt?
 

·
Registered
Joined
·
2,497 Posts
I printed the checks on the bed and it worked. After trying to print on shirts not working I took the shirt off so I wouldn't waist the shirt. So then it printed.
Does it actually try to print the shirt or does it just sit there? are you sure the shirt isn't to high triggering the height sensor?

That's one weird problem.
 

·
Registered
Joined
·
1,286 Posts
I think the laser sensor only stops the bed from moving, it doesn't send any feedback to the printer to prevent it from laying down Ink.

You say you can print on the metal platen, what else can you print on? Paper? Can you put paper on top of the shirt and see if ink lays down on the paper?
 

·
Registered
Joined
·
2,497 Posts
I think the laser sensor only stops the bed from moving, it doesn't send any feedback to the printer to prevent it from laying down Ink.

You say you can print on the metal platen, what else can you print on? Paper? Can you put paper on top of the shirt and see if ink lays down on the paper?

Your right Adam, but we have had cases where the part of the shirt that trips the sensor is right at the edge of the shirt hoop (last thing going in) and the shirt will load but the print head won't move until the shirt is lowered....but normally you'll get the error light to light up when that happens.
 

·
Registered
Joined
·
5,275 Posts
Did you take off the plastic strip underneath the printhead?

Honestly, the burn test is one way of telling but we have had to replace 2 ribbon cables with no burn tests so.. replace the ribbon cable

don't print directly onto the bed.. we use a piece of Plexiglas the size of the platen this way we can hold it up to the light and see how the colors are printing.

this is another way you can tell if you need to replace your printhead because if do two nozzle checks one on each side you can compare them and if they are identical missing lines missing colors then you have a clog.
 

·
Banned
Joined
·
487 Posts
What position is the bed stopping at? If you look you will see the red light shooting across, if it hit something it show up! Hope this helps!
 

·
Registered
Joined
·
6 Posts
Discussion Starter #17
Got it figured out. There was a senosr that is installed on new printheads that some how made it to my machine. The DTG's are not supposed to have a sensor on the head. Now that it is removed we don't have the problem anymore.
 
1 - 18 of 18 Posts
Top