T-Shirt Forums banner

Cyan not printing

1592 Views 7 Replies 3 Participants Last post by  FatKat Printz
My FasTjet has stopped printing cyan. I found that the cartridge and feeder tube had emptied although there was still ink in the bottle. I drew ink into the cartdridge and reset the chip (got a green light)but the cyan is still not working. There is no visible signs of damage to the ribbon cable.
I think I should have clicked the T-jet2. It has the four colors and the white ink upgrade.
I should also note that there are no ink lights blinking. I also tried the Epson utility program and the cyan did not print.
1 - 8 of 8 Posts
how are your nozzle checks? have you tried some ink fills or head cleans?
I had some weirdness like this yesterday.

For us it was the seal on the top of the bulk ink bottles. (there are a few different kinds of bottles, so i'm not sure what you have)

but, check the hoses and the caps. maybe if air is getting in, use some rubber cement or replace the bottles.
My nozzle checks print no cyan. I just replaced the chip on the cartridge, it tested green on the resetter and still no cyan. I am trying to figure out how to test the ink delivery to see if that is ok but my feeling is that it is not getting the signal to print.
if you really feel it's electronic, The place to check is the ribbon cable's connection to the print head - making sure the silver connections are not bent (and if you remove it to check them that they don't go back in bent)

In my experience, this does not sound like an electronic issue, though.

I would do this (and since i'm not a certified tech, there's some stuff I do that others don't advocate, but has worked for me):
1. pop out the cyan cartridge and the 2 on either side. use a needle nose pliers to slip the tube syringe over the cyan nipple in the carriage. Then push some windex and / or cleaning solution through the nozzle. Make sure it doesn't drip into the head, then replace everything and do a few head cleanings to get the cyan back through the head.

2. put your finger over the air hole in the bulk ink bottle and squeeze. notice if any bubbles or air coming from the top of the bottle lids.
ribbon cable could be a problem when it does not print certain colors

how old is the ribbon cable/printhead??
You suggested pushing cleaner through the cyan nipple which will pass through the print head. Than you said not to get any solution on the print head. Am I missing something? I also noted a small air bubble in the ink tube going to the cartridge. I have had these before and the bubble moves when ever there is a head cleaning. This bubble does not move.
what he means is don't let it drip towards the ribbon cable because this will pop the motherboard fuse.. you need to be extremely careful when doing this. move the head to the center of the printer..

I would check your ribbon cable before doing this and after doing this.. you will not hear anything if its pops.
1 - 8 of 8 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.