T-Shirt Forums banner

1 - 8 of 8 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter #1
Hi, I recently bought a new CT630 plotter but can't seem to get it to work. I've tried the whole SignBlazer thing but it only worked a day, I also have FlexiSign got it to work on that on the same day but the next day it was like the plotter didn't even exist. I've watched the set up videos and to be honest I've worked with plotters, large format printers and routers before but this is a first for me. I've tried it on XP, Vista and 7. HELP PLEASE! before I send this back.
 

·
Registered
Joined
·
1,959 Posts
I cannot speak for Vista and 7, but this should not happen on XP. It sounds like your driver is being deleted somehow. Does this happen on ALL three OS?
 

·
Registered
Joined
·
4 Posts
Discussion Starter #3
Hi Nick, the plotter is actually a KCut Pro CA24(CA630) and I did get bit to work on a desktop running WinXP but the desktop just quit on me. After that I tried to run it off 3 laptops, 1 on XP, Vista and the other on 7. I loaded the drives on the disc but there doesn't appear to be any communication with the plotter. I'm starting to think that maybe I need to use a desktop with a serial port as the usb connection doesn't seem to work on this hardware. I am even thinking of returning it but it was really cheap and I can't afford the other brands.
 

·
Registered
Joined
·
64 Posts
I am running 2 creation p-cuts on xp2000,vista, and win7. with signblazer. Laptops and desktops

Everyone says serial instead of USB is the way to go, but I've never had problems either way.

I would check the output device in the cutter settings menu sometimes it drops out. Also sometimes after cutting a design or two, some (including me ) need to turn the cutter off and back on again before making another cut. I don't remember what causes that

I would also try VinylForum.org - Index Most or the people there are from the UScutter forum and would be happy to help (large Knowledge base)

Good Luck
Pete G






.
 
  • Like
Reactions: nameless

·
Registered
Joined
·
64 Posts
Sue, I have seen a rash of problems with Kcut (some variation of the creation 630 machine)

I would check the output device in the cutter settings menu sometimes it drops out. Also sometimes after cutting a design or two, some (including me ) need to turn the cutter off and back on again before making another cut. I don't remember what causes that

I would contact the MFG and/or join and ask the people at VinylForum.org - Index many of them have a lot of experience with some form of the 630


Good Luck
Pete G



.
 
  • Like
Reactions: nameless

·
Registered
Joined
·
1,959 Posts
Hi Nick, the plotter is actually a KCut Pro CA24(CA630) and I did get bit to work on a desktop running WinXP but the desktop just quit on me. After that I tried to run it off 3 laptops, 1 on XP, Vista and the other on 7. I loaded the drives on the disc but there doesn't appear to be any communication with the plotter. I'm starting to think that maybe I need to use a desktop with a serial port as the usb connection doesn't seem to work on this hardware. I am even thinking of returning it but it was really cheap and I can't afford the other brands.
The USB port on the cutter is not a "true USB" port. Windows looks at it as a com port. Go into your driver for the USB port and check to see which com port it is set at and that it is not conflicting with another one.
 
1 - 8 of 8 Posts
Top