T-Shirt Forums banner

Azon troubleshooting

1959 Views 4 Replies 4 Participants Last post by  TeesInPrinting
Hi all,
we're a small DTG online shop based in Hamburg, Germany that's just starting out. But so far we're having issues with our Azon TexPro2 DTG printer. I've tried searching for posts about this printer, but there are just a few. It's basically a modified Epson 4880.

After some trouble with the white color clogging up the pipes, we've got it to work. The white layer by itself looks great. The color layer by itself also looks great.
Combining them on a dark t-shirt results in a weird effect where the color layer starts at the right position on top of the platen, but as it _prints_ further down, the offset increases and the white layer bleeds from the top side.
I've put an emphasis on prints, because if i print some text on top of the platen, and some other text on the bottom, the effect is not present. In that case the printer 'scrolls' down the platen to the right position.

You can see some test prints here.

I've tried cleaning the round encoder, but no difference. Feed / choke settings in PowerRIP all 0 for now. Bidirectional print.
Contacted the manufacturer, but after a few emails they've stopped being helpful and want us to ship them the whole printer to Croatia for diagnostics and repairs. Which is not an option.

Any ideas/advices how to solve this? :confused:
1 - 5 of 5 Posts
I would try to put some glue on the platen to see if it is not the garment that shrink when the white layer dried.
Solution found: connect the printer via UTP, not USB.

No idea why it would matter, but it obviously does.
Solution found: connect the printer via UTP, not USB.

No idea why it would matter, but it obviously does.

Your 4880 print engine has both the ethernet and usb ports on the main board. Either should work. The fact that only the ethernet works could be something in the RIP you are using not recognizing the port. But as long as you got it going it really doesn't matter.

Hello... I'm using an Azon Tex Pro and have problems with it. I have made several power cleanings and still get a "Low ink" message on the black, but all the cartridges are full. What can I do?

I have also resetted the cartridge too.
1 - 5 of 5 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.