T-Shirt Forums

T-Shirt Forums (https://www.t-shirtforums.com/)
-   T shirt Printing Issues (https://www.t-shirtforums.com/t-shirt-printing-issues/)
-   -   Emulsion issues need guidance (https://www.t-shirtforums.com/t-shirt-printing-issues/t883383.html)

justincase3000 January 26th, 2020 08:33 AM

Emulsion issues need guidance
 
I am using chroma blue. Its not past its date, I mixed it at least one hour prior to using. I keep it inside my house so the environment its controlled(never below 65 or above 75).

When coating 156 screens it looks like its runny. Some areas seem to have more emulsion than others. I put even pressure and can hear the screen scream as im coating. I have tried both edges of the scoop, I have done one to one coat. 1-1-1 coat, 2 to 1 coat. I just purchased matsui screens( I think thats the name), thinking it was the ebay screens the issue. Still same problem. Here is the kicker, my 230 screens come out perfect every time. Thats reason I thought it was the screens but still have the same issues with brand new screens.

Not sure what to do from here.

mrbold January 28th, 2020 03:20 PM

Re: Emulsion issues need guidance
 
I used to use chroma blue and found it to be a bit runny for the low emulsions. Some areas would be darker than others once it was dry. It still worked okay. I switched to chromotech PL. It's a lot more expensive, but it exposes greate, coats easy and best of all reclaims quickly.


All times are GMT -8. The time now is 08:48 AM.

vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2020 DragonByte Technologies Ltd.
Copyright 2004-2014 T-ShirtForums.com. All rights reserved.